Results 1 to 4 of 4

Thread: IC-308 network and engine connectivity issues

  1. #1
    Join Date
    Nov 2013

    Default IC-308 network and engine connectivity issues

    Hi. I have a Fiery IC-308 connected to a KM C1070 that has some network connectivity issues. It will not recognize the network and does not assign addresses therefore won't connect to the network. It also intermittently loses connection to the engine. I have tried reloading system software but that did not resolve the issue. I noticed if you reboot the Fiery, and when you open CWS, it assigns weird IP addresses to the CWS for example,, or It never shows the IP address on CWS that I manually entered for the Fiery.

    The issue started yesterday as it intermittently was dropping off the network and now it's completely down. We tested the network and it's ok.

    The Fiery is only 3 months old. I suspect a hardware issue with the motherboard as this unit does not have a dedicated network card. Is this a fair assumption?


  2. #2
    Join Date
    Jul 2016


    Did this ever get resolved? I am having a similar issue on a km 1060 with an ic-308. Ive done all the updates (windows and CWS) that it will let me do and i still get a message at the top that says "Establishing Network Communication". I've also tried known good network cables.

  3. #3
    adam1991 is offline Fiery Forum Expert Contributor adam1991 has proven very helpful adam1991 has proven very helpful adam1991 has proven very helpful adam1991 has proven very helpful adam1991 has proven very helpful
    Join Date
    Feb 2010


    The KM system requires not only the thick cable connection between Fiery and engine, but also a network cable to the VI board installed in the engine.

    "Establishing network communication" is an error in that particular connection, not in the network connection to your corporate network. If the Fiery-to-engine communication isn't working, place a service call and let them work through it.

  4. #4
    Join Date
    Apr 2012



    "Establishing network communication"

    Do you have any ideas for this problem?
    We tried change the both cables and VI board..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts