My end user (a Mac user) recently applied some long-pending updates to MacOS. Afterward, he was prompted to update the Fiery applications. He did so. When launching Fiery Navigator, he was prompted to register a server. The Fiery on our network appeared, and he entered the password. However, after clicking the Register button, he received the message "The device is not supported".

Is this some sort of software version conflict? How might I troubleshoot this issue?