Results 1 to 6 of 6

Thread: Mac OS X Sierra (10.12) and WorkCentre 78xx

  1. #1
    Join Date
    Feb 2017
    Posts
    4

    Question Mac OS X Sierra (10.12) and WorkCentre 78xx

    Hello,

    We've been patiently waiting for a while for EFI drivers to come out for Mac OS X 10.12 and WorkCentre 7845 -- but still it appears they are not available on neither the Xerox website nor the EFI website. Do you guys intend to release these drivers in the near future? Are there any alternatives that would work in the meantime?

    Thanks,
    Andy

  2. #2
    Join Date
    Jun 2015
    Posts
    116

    Default

    Hi Andy,

    The 10.12 drivers for all supported products were posted Nov 2016. But, I think I understand what happened here. So for your product, WorkCentre 78xx, a newer version was released in the market. When customers have a free upgrade to the newest version, sometimes only the drivers for the newest version is provided. The drivers for the newest version will be backwards compatible.

    Direct link to your driver: WorkCentre 78xx

    Screenshot of where to find driver: Driver location

    Please try installing that and let me know if you're having any issues.

  3. #3
    Join Date
    Feb 2017
    Posts
    4

    Default

    Thanks for the response.

    I've tried that driver and it fails to install. I did the Firey Uninstaller first. (which found no existing drivers/printers).

    The one named "XC_WorkCentre78xx_v1_1R_FD50_v1.dmg" successfully installs but it always fails to print with error message "Invalid Account ID"; despite that information being saved in the preset with the Xerox Standard Accounting option set.

  4. #4
    Join Date
    Jun 2015
    Posts
    116

    Default

    Hi Andy,

    We are having some trouble replicating the issue. Can you give us some more information so we can continue our tests?

    1. OS Version (latest version is 10.12.4)
    2. Error message that occurs when you tried to install this driver
    3. OS preferred language & primary OS language
    4. If possible, please send us your installer log. This can be captured by double clicking on the PKG file to install the driver, then going to the Window menu and selecting "Installer Logs".

    Thanks,
    Anthony

  5. #5
    Join Date
    Feb 2017
    Posts
    4

    Default

    Quote Originally Posted by Anthony.L View Post
    Hi Andy,

    We are having some trouble replicating the issue. Can you give us some more information so we can continue our tests?

    1. OS Version (latest version is 10.12.4)
    2. Error message that occurs when you tried to install this driver
    3. OS preferred language & primary OS language
    4. If possible, please send us your installer log. This can be captured by double clicking on the PKG file to install the driver, then going to the Window menu and selecting "Installer Logs".

    Thanks,
    Anthony
    1. 10.12.3
    2. The installer doesn't even detect the printer; even when typing in the IP. So I select the option "Install the driver only" then manually add the printer using that driver via the "Select Software" option. I've tried every protocol. I always get the error "invalid account ID" on the printer completed log and the job doesn't print. On older OS versions I always used Xerox Standard Accounting and put in the value for the User ID field.
    3. English

    I've tried setting up the printer on two Sierra macs without success with the linked driver.

  6. #6
    Join Date
    Feb 2017
    Posts
    4

    Default

    I discovered that the driver works when the accounting system on the printer is turned off. Have you guys tested your drivers with a printer that has accounting turned on?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts