My concern stemmed from one of the situations being Macintosh, the other Windows.

I just tested, and can tell you that the Impose dongle worked fine on Mac OS 10.10.5 running both CWS 5.7.0.29a and 5.8.0.74a.

If there's truly an issue with the Macintosh site, it's probably local to that--unless they have a CWS version that isn't 5.8.0.74a...