+ Reply to Thread
Results 1 to 1 of 1

Thread: Information on Fiery drivers and macOS Sierra 10.12

  1. #1
    Join Date
    Jun 2015

    Default Information on Fiery drivers and macOS Sierra 10.12

    Information on Fiery drivers and macOS Sierra 10.12 - Other Languages Here

    On September 20, Apple released the new macOS Sierra 10.12 operating system. If you are using an English version of our current Fiery driver already installed on your Mac, it will be compatible with macOS Sierra 10.12. EFI is working diligently to provide Fiery drivers with support for macOS Sierra 10.12 in all supported languages and for new installations of our Mac drivers. We expect to release an update to our Mac drivers to resolve issues with language support through Fiery Driver Updater by September 26.

    In order to utilize Fiery Driver Updater, please ensure that you are running the latest version of the Fiery driver for your printer (Fiery Driver 5.0). These latest drivers are available through the EFI Download Center.

    If you have a business critical need for a macOS Sierra 10.12 driver in a language other than English prior to September 26, please contact your printer manufacturer's tech support, who will be able to assist you.

    We will update this thread when the update is available through Fiery Driver Updater.

    Update 9/28 – Additional issues have been encountered during our tests. We are continuing to investigate these issues.
    Update 10/21 – The update is now available through Fiery Driver Updater, starting with select regions.
    Last edited by Anthony.L; 10-21-2016 at 11:15 AM.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts