Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: Trouble connecting to MX-7500

  1. #1
    nferrell is offline Fiery Certified Professional nferrell is on a distinguished path
    Join Date
    Mar 2014
    Posts
    4

    Default Trouble connecting to MX-7500

    My company recently purchased a Sharp MX-7500 Polaris Pro with Fiery MX-PE10 for our showroom(we are a Sharp dealer). After setup, everything seemed to be working fine. Upon running some VDP jobs for testing for a potential client, it started acting strange. The booklets being run would change during the run. For example, booklet one would print and staple perfectly. Booklet two would print sheet one fine, the backs of sheets two, three, and four, and the remaining five sheets would be completely blank. Booklet three would print entirely blank, although it would staple it properly. Anything printed after that would come out blank until rebooting the system. Thinking it was an issue with the machine, I called Sharp and they suggested reloading the Fiery system software and confirming the latest firmware on the machine. I did so and now the Fiery server will NOT connect to the MFP at all. The Fiery bar at the top of the display shows "Check copier power and cable connections". I have already removed the back panel from the machine and reseated all connections to the piggyback board and from that board to the MFPs board. I have also reseated the three cables and network cable from the machine to the server and verified the cables are in the right location. Any thoughts?

  2. #2
    Ranjitha is offline Fiery Forum Expert Contributor Ranjitha is on a distinguished path
    Join Date
    Jun 2012
    Posts
    122

    Default

    Can you try rebooting both Engine & Fiery.

  3. #3
    nferrell is offline Fiery Certified Professional nferrell is on a distinguished path
    Join Date
    Mar 2014
    Posts
    4

    Default

    Tried that many times. I've ordered a new interface board for the MFP. I believe this will solve my issue.

  4. #4
    Join Date
    Jun 2014
    Location
    Plymouth, United Kingdom
    Posts
    4

    Default Re: Trouble connecting to MX-7500

    Quote Originally Posted by nferrell View Post
    Tried that many times. I've ordered a new interface board for the MFP. I believe this will solve my issue.
    How did changing the interface board go - did it solve your problem?

    I have a Sharp MX-7500 with MX-PE10 Fiery Controller in a production environment currently and it is exhibiting similar symptoms, mainly limited to random colour changes on random pages throughout a run with the occasional missing page.

    Would be interested to know.

  5. #5
    nferrell is offline Fiery Certified Professional nferrell is on a distinguished path
    Join Date
    Mar 2014
    Posts
    4

    Default

    Changing the interface board in the back of the machine resolved my issue. If you've already updated/reformatted the system software, I would say that it's worth a shot.

  6. #6
    Join Date
    Jan 2014
    Location
    Melbourne Australia
    Posts
    9

    Default

    Yep, the PX10 Interface board in the engine has been updated to deal with a few problems.
    If you encounter this issue, a 'dead' Fiery controller panel (although unit is operational), a 'dead' engine operation panel (although engine is operational), or a message 'Power Surge on Hub Port', replace the interface board.
    The updated part number ends in DS53 instead of DS52. Look for the '53' written on the white box printed on the board.
    Always shutdown via the operation panel first, on both engine & Fiery controller before powering off engine via main switch inside front door. Powering off & on again via the main switch first can damage the interface board DC converter.


    Service Pack 2 Patch FIT38605 also has a fix for the message 'Check copier power & cable connections' listed here. Check the System Update Log to confirm this patch is installed.


  7. #7
    Join Date
    Jan 2015
    Posts
    3

    Default Fit38605

    Hi Warren

    How can i download FIT38605 ? or where

    Thanks


    Quote Originally Posted by Warren-SharpAus View Post
    Yep, the PX10 Interface board in the engine has been updated to deal with a few problems.
    If you encounter this issue, a 'dead' Fiery controller panel (although unit is operational), a 'dead' engine operation panel (although engine is operational), or a message 'Power Surge on Hub Port', replace the interface board.
    The updated part number ends in DS53 instead of DS52. Look for the '53' written on the white box printed on the board.
    Always shutdown via the operation panel first, on both engine & Fiery controller before powering off engine via main switch inside front door. Powering off & on again via the main switch first can damage the interface board DC converter.


    Service Pack 2 Patch FIT38605 also has a fix for the message 'Check copier power & cable connections' listed here. Check the System Update Log to confirm this patch is installed.

  8. #8
    Join Date
    Jan 2014
    Location
    Melbourne Australia
    Posts
    9

    Default

    The fiery can download the updates automatically if connected to internet (via Fiery software manager tool), you can manually download the updates and install manually or your Sharp rep can install all the patches & service packs.

    The patch in question here was released in December 2013 (its now January 2015), and there has been numerous updates since as well. If your Fiery hasn't had these updates done in that time, you really need to get these done. There have been heaps of improvements & functionalities added now.


  9. #9
    Join Date
    Jan 2015
    Posts
    3

    Default 'Check copier power & cable connections'

    Yes questions old, but i have same problem.


    All software updated. Fiery System update and Machine firmware.
    Our company distributor of Sharp. we still did not answer the sharp Tech. Dept. ( SEEE )
    Have you propose another solution ? Thanks for help.


    Quote Originally Posted by Warren-SharpAus View Post
    The fiery can download the updates automatically if connected to internet (via Fiery software manager tool), you can manually download the updates and install manually or your Sharp rep can install all the patches & service packs.

    The patch in question here was released in December 2013 (its now January 2015), and there has been numerous updates since as well. If your Fiery hasn't had these updates done in that time, you really need to get these done. There have been heaps of improvements & functionalities added now.

  10. #10
    Join Date
    Jan 2014
    Location
    Melbourne Australia
    Posts
    9

    Default

    You are aware that there is a specific order in which to apply the updates? Installing updates in the wrong order can cause incorrect bootup and/or messages.

    You've done the basics such as confirm working NICs on both engine & fiery, correct network cabling in use, current firmware & all patches, run Fiery configure, actually reseat the interface board & cabling to Fiery controller from engine, confirm correct DC power to interface board, booting up machine in correct order etc etc....

    You have no comms between engine & Fiery. After checking the above, could definitely be the interface board PX10 as mentioned earlier.


Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts