Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: hot folders start up and memory leak problems

  1. #1
    Join Date
    Dec 2009
    Posts
    4

    Default hot folders start up and memory leak problems

    Hello. I'm running Hot Folders 2.5.0.10 on a 32-bit Windows 2003 Server.

    The Fiery engine is: Fiery X3eTY2 65-55C-KM and it's connected to a Konica-Minolta Bizhub Pro C5501.

    I am having two problems.

    1) When the server is rebooted, Hot Folders appears to start up alright. I see the GUI on the screen and the Hot Folder icon in the system tray. However, no documents are processed. I can write to the hot folder directories and nothing happens. They just sit there. If I exit hot folders from the system tray and restart it, then it works fine.

    2) The hffw.exe process eats more and more non-paged memory and it never stops and never gives the memory back until the system crashes. I can see this happening in the task manager. I added the column NP Memory and can watch it increase by 10k or so every click. If I exit hot folders and restart it, then the memory is released. If I don't exit hot folders, the system will crash when the RAM is all used up. This is the second machine that I have seen exhibiting this behavior.

    I really only need to fix one of these problems. My first solution was to run a script every couple hours that would kill the hffw.exe process and restart it. I did this via the following batch script:

    taskkill /IM hffw.exe
    taskkill /IM hfgui.exe
    taskkill /IM hfps.exe
    cd "c:\program files\Fiery\HotFolder\"
    start "hfgui process" hfgui.exe

    However, from time to time, this would fail and I couldn't figure out exactly why. I would access the server and hot folders wouldn't be started at all... or there would be two hot folders icons in the system tray. So, it didn't work all the time as I had hoped it would.

    My next solution was to reboot the server every night ... but problem #1 from above is now getting in the way.

    Any ideas? I see that Hot Folders 2.6 is available... does anyone know where I might be able to access a changelog or release notes for the new version? Are these bugs addressed? Where on the EFI web site can I download the newest versions? I googled it and found the install file on some IBM server.

    Thanks in advance for your help.

  2. #2
    Join Date
    May 2009
    Location
    Minneapolis, MN
    Posts
    343

    Default

    Can you give us some information as to how you are using your hot folders? For example:
    How many hot folders do you have enabled?
    How may files you are typically processing through the hot folders during a day?
    What is the typical size range of the hot folders?
    Are the hot folders shared to allow users from other workstations to drop files into them?
    Are the hot folders configured to keep the files after transfer to the Fiery?

    You may want to try Hot Folders 3.1.0.24 which is available as part of the Fiery Utilities Release 3b package that is available for download at http://www.efi.com/support/download-software.asp. Choose “Fiery Application Package 3b” from the EFI Software section.

    Bob

  3. #3
    Join Date
    Dec 2009
    Posts
    4

    Default more info

    1) I have 28 hot folders enabled

    2) Probably a couple hundred per day. Maybe a little more... but on the order of more than 100 but less than 500.

    3) When you say 'size range' of the hot folder, what exactly do you mean? If you mean the size range of the documents being processed... then they are between 20K-500K PDF files.

    4) Yes. There are two machines involved. One is running hot folders and the other (the web server) is writing files across the network to the hot folder server. Originally, I had hot folders running directly on the web server, but that didn't work out due to the memory leak. So I was forced to move hot folders to another server for the time being at least.

    5) No. I have not changed a config option that would keep files after sending to the Fiery. And I can confirm that that the PDFs are deleted when processed.

    I'm going to install the newest version now and will report on my results as soon as I know.

    Thanks for your help. I really appreciate it.

  4. #4
    Join Date
    Dec 2009
    Posts
    4

    Default problem with 3.1 installation

    I uninstalled 2.5.0.10 no problem.

    I installed 3.1 no problem.

    I create a new hotfolder.

    I select the server. No problem.

    I click the 'Define' button next to Job Properties. Nothing happens at all.

    Rebooted. Nothing.

    I've shut down our printing operation thinking this would be quick upgrade. And now unless I can figure this out fast or hear from you, it looks like I'll have to quickly revert to 2.5.

    Any quick advice for me?

  5. #5
    Join Date
    Dec 2009
    Posts
    4

    Default update

    3.1 is up and running now. I uninstalled and reinstalled including command workstation this time.

    And this time it detected my old hotfolder settings and imported them. Remember... I had 28 hotfolders set up. And the print settings are pretty complicated. Cover sheet insertions from different trays and all that. So... that import saved me some time. Nice!

    And now I can click a job and view the print properties no problem.

    I'll report on the memory issue as it comes up.

    Thanks and sorry if I wasted any of your time with that last post.

  6. #6
    Join Date
    Aug 2009
    Location
    Belgium
    Posts
    5

    Default

    Interesting! We got almost the same configuration and exactly the same 2 problems!! Running EFI Hot Folders 2.5.0.10 on a Windows XP system with a Fiery engine 'Fiery X3eTY2 65-55C-KM' with an Oce CS-620 printer.
    It's remarkable to read your thread, as I also work with the same workarounds; restart the hffw via a batch etc.
    But still, after a weekend or something, I always need to manually disable the Hot Folder queues and manually enable them again. In fact, sometimes I need to do this several times a day.

    The problem DRIVES ME NUTS! I get 'zero' support from Oce and EFI Fiery, they do not have a clue what I was talking about. Another 'isolated problem'. But I'm glad in some way I'm not the only one that is struggling with this very annoying problem...

  7. #7
    Join Date
    May 2009
    Location
    Minneapolis, MN
    Posts
    343

    Default

    Have you tried Hot Folders version 3.1.0.24? This is part of the Fiery Utilities Release 3b package that is available at http://www.efi.com/support/download-software.asp. When you enter the site, choose “Fiery Application Package 3b” from the EFI Software section.

  8. #8
    Join Date
    Aug 2009
    Location
    Belgium
    Posts
    5

    Default

    Allright! I will give it a try.
    Is this Hot Folder version 3.1.0.24 fully compatible on a Windows 2000 and/or a Windows 2003 Server?

  9. #9
    Join Date
    May 2009
    Location
    Minneapolis, MN
    Posts
    343

    Default

    Hot Folder version 3.1.0.24 is compatible on a Windows 2003 Server. It is not compatible on a Windows 2000 Server.

  10. #10
    Join Date
    Nov 2011
    Posts
    5

    Default Fiery App Package 3b or 3d-Hot Folder version 3.1.0.24

    Is Hot Folder version 3.1.0.24 compatible with Windows 2008?
    We are having the memory leak issue right now, so we disabled the hot folders.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts