PDA

View Full Version : EFI Developer ID is expired message at Driver Installation on MOC OSX 10.12.3



lepo2005
03-30-2017, 07:20 AM
I have this message at the Driver Installation. I can install the Driver, if i press the trust button, but
i havenīt the "view all Settings button in the Printer Dialog. also the bidirectional communication is lost.

Mike_R
03-30-2017, 02:54 PM
We have identified a problem with how the software installer is using certificates on the Mac, which prevents installation, and are working to address this. This applies to printer drivers, Command WorkStation, and Color Profiler Suite. As we have more information we will post to this forum.

-Mike

Mike_R
03-30-2017, 06:55 PM
While we have posted Command WorkStation v5.8.0.94 for Macintosh, available via Fiery Software Manager, which addresses this problem for CWS, we are still working on a solution for the printer drivers and CPS.

-Mike

donmontalvo
03-31-2017, 05:36 PM
Check if the signature is expired:


pkgutil --check-signature /path/to/package.pkg

Create three folders and put the PKG that has the expired signature into the OLD folder:



OLD/package.pkg
TMP/
NEW/

Expand the PKG in the OLD folder and send it to TMP folder:


pkgutil --expand /path/to/OLD/package.pkg /path/to/TMP/package.pkg

Flatten the expanded folder in TMP folder and send it to the NEW folder:


pkgutil --flatten /path/to/TMP/package.pkg /path/to/NEW/package.pkg

Done...expired signature removed, the PKG in the NEW folder is now usable.

PS, sent an IM to one of the guys responsible for these PKGs, so he can fix.

Don

donmontalvo
03-31-2017, 05:50 PM
Well dang...didn't know there were embedded PKGs in the PKG.

Maybe it would be easier to redesign the PKG so it is a single/flat, and less convoluted PKG? :D

donmontalvo
03-31-2017, 05:53 PM
While we have posted Command WorkStation v5.8.0.94 for Macintosh, available via Fiery Software Manager, which addresses this problem for CWS, we are still working on a solution for the printer drivers and CPS.

-Mike

FWIW has nothing to do with how macOS handles certs...the Developer ID used by EFI dev team is expired.

Mike_R
04-01-2017, 08:28 AM
We have posted updated versions of Color Profiler Suite in the efi.com Download Center (http://www.efi.com/support-and-downloads/download-center/?type=&oem=&sid=&model=&os=) that address this issue, and are working on a patch for printer drivers to allow them be successfully installed. This printer driver patch should be available shortly.

-Mike