View Full Version : OSX 10.10 Cups Filter Crashes

11-13-2014, 02:21 PM
customer has osx 10.10 with ic-414 on a bizhub c554e. I have been out there twice doing banner printing with her and has worked fine for me while onsite. Today i installed all the necessary patches for the fiery system running version 1.2, after i left customer tried again and every time customer prints it crashes the CUPS filter on there MAC. Just wondering if its a print driver issue or a CUPS issue. Customer is trying to print from adobe acrobat pro X. Also i have noticed when i print using the fiery driver trying banner printing the job seems to fail and the error reads data size too large.

11-13-2014, 02:37 PM
Since this is a 10.10 Yosemite Mac, download IC-414 v1.2 Yosemite print driver from EFI.com driver download page. Use Fiery uninstaller tool that comes with it to first uninstall existing printer AND driver.

Then configure new printer using downloaded driver.

Next, get patch FIT224385 from KM Tech Support and install it on IC-414.

You should then be able to print banners from that Mac

11-13-2014, 04:14 PM
I did install the patch and i did install the ic-414 driver for v1.2, the CUPS filter was still crashing

11-18-2014, 08:50 AM
Our 10.10 drivers sometimes conflict with existing drivers on the mac. We are working on a fix for this.

In the meantime, I recommend removing all printers currently installed, running the Fiery Software Uninstaller to remove all Fiery print drivers, and then installing the 10.10 compatible driver fresh.

Let us know if this fixes the problem.