View Full Version : OS X 10.10 Yosemite driver issue

10-21-2014, 07:32 AM
I have downloaded the most recent drivers for OS X 10.10 for my 2 Ricoh printers. C751EX Pro & C720S.

I see a common issue with both of them…. the 2-way communication in the driver does not work.

When checked on I get the following error:

You have entered an invalid IP Address or DNS Name.
Press OK to enter a new IP Address or DNS Name.

The problem is the field for the address cannot be typed into, it’s un-editable.

Any ideas????


10-22-2014, 06:11 AM
Hi Tony,

Bidi has changed in 10.10. What you're describing is documented in the release notes.
Please see attached,.

Kind regards,

10-22-2014, 11:51 AM
Can you please try removing all Fiery print drivers using the Fiery Software Uninstaller, and then install the printer again?

If still no luck, try adding the printer as an IP printer (LPD port) instead of Bonjour.

Let us know how it goes.


10-22-2014, 04:11 PM
Thanks for the response and for the release notes.

I've uninstalled all Fiery Software, Printers, and Print Drivers. Then reinstalled the driver for the Ricoh C751EX and added it an LPD printer. So far so good.

Unless I'm misunderstanding the release notes, Two-way communication can no longer be used, so it must be left off, but the OS should still retrieve info from the Fiery via the new daemon.

So I click on "Full Properties..." and the choice for "Paper Catalog" is missing and does not show up no matter how long I wait, or close and reopen the "Full Properties..." dialog.

Am I missing something?

Thanks for the help.


10-23-2014, 07:44 AM
I deleted the printer and started over (again) and it is now working.

Thanks for the help....


11-18-2014, 08:26 AM
I am seeing this error message too.

Deleted the print queue and drivers, rebooted. Added the driver back, set up print queue with EFI installer or manually. Repeat, repeat, repeat.

I'm still seeing this error message.

Tried LPD, Bonjour and IPP.

Any other suggestions?

12-02-2014, 10:35 PM
Hi Greta, I am having the same problem here. I deleted drivers & printers using the uninstall tool. I have downloaded the Xerox 560 with Integrated Fiery from your site and added the printer as bonjour, LPD, and IPP as per the release notes but still get the IP/DNS invalid error. I had a look at the activity monitor and did not find the processes fieryd & fiery_bidi. I suspect these are failing to be installed when the driver is installed. I even went into the security settings to allow applications to be installed from Anywhere. Hopefully you can come up with a solution. Regards Craig

12-04-2014, 01:48 PM
So I too was having issues with the method described, but with some playing around, seemed to have figured it out. This method worked for us using Mac OS 10.10 and the efi driver for the Ricoh Pro C651. This has been successful for 3 Mac Pro's we have.

The procedure I used was this;
1. Remove all previous versions of the driver from the machine and reboot.
2. Install the latest driver from the downloads.
3. Add the printer but install using the IP method.
4. Enter the IP address of the server hosting the printer.
5. Choose LPD.
6. Enter the print queue(I entered "192.168.10.X/direct" for our print queue to use. This may work if you take the default print queue if left blank).
7. The name should have populated as the IP address *This was the key part for myself to get it to work* Leave the name as it defaults to the IP Address.
8. Pick the driver from software that was installed.
9. Make any configurations for your printer as needed.
10. Open a document and try to print, go to the 2 way communications check box and check it.
11. Open the properties and it should now work.
12. Once it has been confirmed working, you can now rename the printer to something more user friendly.

I think that once the printer is able to make initial contact with the Machine, that it resolves the IP/DNS for that printer, which at that point can be renamed.

Hope that this helps as we are now up and running properly again using the above.

01-13-2015, 10:38 AM
Here's a link to a patch for you to try.
Just simply install it over the top.

https://www.dropbox.com/s/4qes3pkipvkd7ij/Fiery%20Printer%20Driver%2010.10%20patchJan9.dmg.z ip?dl=0

Let us know how it goes.