View Full Version : 10.9 and CS6 properties open slow

pete b
10-16-2014, 05:03 PM
I have a Konica C7000 and a IC306v2 and when selecting Fiery Features I am seeing a 30 second delay. I have not had this issue with previous driver/OS..

10-27-2014, 10:49 AM
I am getting the same latency issue you are experiencing when using the Fiery Ricoh E42B V1 driver for a Ricoh C5100s printer/copier, and I am running Adobe CC 2014 on OSX 10.9.5 . When I click on "Printer" in any Adobe application Print dialog box, I get about 2030 seconds of spinning pinwheel lag before it recovers. This happens in the Fiery windows consistently. Any assistance or diagnosis of this issue would be helpful.

11-20-2014, 08:04 AM
I have the same issues and i have never been able to fix and fiery hasn't been the greatest of help. Additionally I can select whatever option i want, after that long delay, but they are completely ignored by the fiery workstation. I have to print the job once then go into workstation and set the attributes manually.

If you find a work around let me know.


11-20-2014, 08:21 AM
It is difficult to help without details.

* What Fiery model and what system software version?
* What is connected model printer?
* What OS version is your Mac running?
* From what applictions do you observe this issue in, and what versions are they?
* Where did you get print driver you are using and does it support Mac OS you are using?
* Have you tried going to EFI.com and downloading latest Mac printer driver for you Fiery?
* before installing newer Fiery print driver did you run Fiery Mac uninstaller tool to remove previous printer AND driver?

11-24-2014, 01:06 PM
Thanks for the response Scott W. Here are my deets:

Fiery Model: Color Controller E-42B, software: v1.1 (graphic arts package v1, adv controller interface kit)
Printer: Ricoh Pro C5100s
Mac OSX 10.9.5
We are observing the issue in every printer dialog box that allows us access to Fiery Features. All of MS Office 2011, All browsers, Preview, and Adobe CC 2014 apps. Basically any app that allows printing.
I got the driver from the EFI site: http://w3.efi.com
I have tried EFI's site, and I am using the correct driver for the device and OSX: E42B for the Ricoh C5100s
I have ran the installer/uninstaller multiple times, I wouldn't post on this forum w/o troubleshooting any obvious solutions first. I made sure that after the uninstaller ran that there was no detection of the fiery software or the driver in between re-installing.

At first we thought it was just Adobe CC2014, but after testing MS Office 2011, Firefox 33, Chrome, Safari, Preview, Coda 2, we found that all print dialog boxes were effected by the latency issue. It will take 20-30 seconds of pinwheel time before your input is accepted in the Printer Dialog Boxes once you pick the Fiery Queue for the C5100s. We have Ricoh looking into it as well, and they have came to our labs and tried to diagnose the issue, but ran into the same problems after troubleshooting it from their end.Right now, we are unable to effectively use the fiery driver, it takes about 2 minutes to get through all of the latency every time you print using it, and our staff/end users are unwilling to endure that. So this is a major issue for us. For now we are using a Ricoh Post Script driver for the C5100s that is fairly generic, and does not afford us all of the options that Fiery Workstation. I have found others in the EFI Mac OSX forums with the same issue, so we know we're not the only ones experiencing this latency.

01-06-2015, 12:08 PM
Still having the same issue, and I have posted my details above. A response to this thread would be greatly appreciated, thanks.

01-09-2015, 08:36 AM
Have you tried disabling two way communication? It could be that the Fiery driver is having trouble contacting the Fiery controller over the network.

I found on my Mac 10.9 box that if two way communication is unchecked, the driver (launched from full properties button) loads in about 1-2 seconds, often faster.


01-21-2015, 11:51 AM
Thanks for the response Greta. I assure you that 2-Way is off, and always has been in my labs. I've provided a screenshot to show this. 2 seconds faster would still be 28 seconds of pinwheel lag, which is unusable in my work environment.


02-04-2015, 09:11 AM
Hi Julian,

I understand your frustration, I'm also a bit miffed by this one, as it appears we have the same driver, same MacOS version, same apps, but a completely different experience. So let's check the details.

To confirm, here's my setup:
MacOS 10.9.5
Fiery Driver Pro C5100Sseries E-42B PS 1.1, I downloaded the driver from efi.com website, see screenshot below. Before installing I removed all Fiery drivers, using the Fiery Software Uninstaller version included with the downloaded driver.
When installing, I selected 'Install printer driver only', as I don't have a Fiery of that model on the network, and it makes for a cleaner test.
I then added a new printer in Sys prefs, using an LPR port pointing to a local Fiery printer I have here. Was careful to select Printer Driver > Other > and then "Ricoh Pro C5100Sseries E-42B PS 1.1" in mac driver popup. I know the website listed it as 1.0, but it's really 1.1 (I checked).
I set this as my default printer for the test.
Two Way Communication turned off
I am running MS office 2011, Word v14.4.7 as per the Word About tab.

Steps to replicate:
1. I open a new word document in Word, typed in one word "test".
2. Select print, and the print dialog comes up instantly
3. I then select Fiery features from the pull down (instant),
4. I can then click on 'Full Properties' and it opens in less than 1 second.

And on your machine it takes around 30 seconds for the same? Can you confirm the steps and where the lag appears?