PDA

View Full Version : Color Profiler Suite 4.6



Phobos01
08-04-2014, 11:36 AM
I just upgraded my CPS to the new version. Unfortunately it will not activate the license for my ES1000. It worked fine before. I downloaded the license and got a message that it was generated. Now i get the attached error.1034 Is the new CPS not compatible with the ES1000? I really need to use this software. Any help would be greatly appreciated.

Thank You

adam1991
08-04-2014, 03:16 PM
For reasons unbeknownst to the real world, EFI considers 4.6 a completely new upgrade, unrelated to 4.0 through 4.5.

Why they didn't just call it 5.0, I don't know.

Anyway, this is a simple licensing issue. If you are licensed--that is, if your spectro serial number is licensed--for version 3.x, you may use any 3.x. If your spectro is licensed for version 4.0, then you're good for any update through 4.5.

But to get version 4.6, one of two things must be true:

a) you bought version 4.6 after it came out, or
b) you were under maintenance contract when version 4.6 came out

CPS ships with a one year maintenance contract out of the box, so those 4.x users who bought as much as 364 days before 4.6 came out are eligible for 4.6 without any extra costs. But those 4.x users who bought 366 days before 4.6 (for example) would not automatically be eligible for the 4.6 upgrade.

You can buy an upgrade from your currently licensed version and then get on maintenance; as long as you're on maintenance, you may continue to upgrade.

At this point, you must uninstall version 4.6 and reinstall whatever version you had before. Or, simply pay the upgrade fee and use the 4.6 you have installed.

Gary_S
08-04-2014, 03:27 PM
It looks like according to your error message, you are licensed for CPS version 3.1. You've installed the 4.6 version, which is a chargeable upgrade to your 3.x version. If you need to use the SW immediately, you can uninstall the 4.6 SW, and reinstall your 3.1 CPS SW.

As you may expect, there have been a lot of new features and enhancements to CPS over the years since the release of your 3.1 version. CPS 4.6 is backwards compatible to your ES1000 spectro. You can get information on whats new in CPS 4.6 at this link:

http://w3.efi.com/Fiery/Products/Workflow-Suite/CPS

Best,

Gary Smith

Phobos01
08-04-2014, 04:04 PM
Is it possible to upgrade my license from a 3x to 4.6? If so how much would that cost?

Thank You

Lou_P
08-12-2014, 03:43 PM
To clairify, there are no upgrades available to CPS 4.x. The product must be kept under software support and maintenance agreement ("SMSA") that entitles the user to tier 1 CPS technical support (email <profilersupport@efi.com>) and to all upgrades.

Because 4.6 shipped at a time when early shipments of 4.0 had SMSAs expiring, a new license is required for 4.6. If you are under SMSA when you download an install 4.6 it will license automatically. If it does not, use the "Renew Now" button in the CPS software update window to renew the SMSA.

For 3.0 users an upgrade is required to get to 4.x, 4.6 today. That upgrade costs $899 US and includes the first year SMSA. Check with your Fiery reseller to order the upgrade or order from the EFI e-store.

rolandthr
04-01-2015, 09:47 AM
When trying to update the SMSA agreement online to acquire the CPS 4.6 upgrade the starting and ending date for the agreement shows Jan 2015 to Jan 2016. When I'm ordering in in April, does this mean the SMSA expires in Jan. 2016 no matter what time of this year it's purchased?

Lou_P
04-01-2015, 11:08 AM
The SMSA needs renewed from the date it expired. It appears your SMSA contract expired in Jan 2015, so the 1 year renewal will take you to Jan 2016. Like any support contract, you have to stay current - if it expires then when you renew you are renewing from the date it expired.

I see earlier in this thread some question about why 4.6 is called a "new" version, and a question about why its not called 5.0.

I can answer the first part. Every dot release of CPS software (first decimal place such as 4.5 to 4.6) adds new features. For example in 4.6 the Express Profiler was added to allow even a beginner to make a Fiery calibration set and output profile and link these together into a preset or virtual printer in only five steps. This same process used to require the use of Fiery Calibrator and Color Profiler Suite and took many mpre steps p[lus training on the procedure to succeed.

Whenever a software company adds features to a product, they are required by law to sell an upgrade =- otherwise it is as if the software firm owed you a feature and charged you for it when you bought the software. Rather than make users buy an upgrade every time we add features (costs almost $900 for the last upgrade available from CPS 3 to 4) , we instead have gone to the SMSA model. Now for only $400 per year you get all upgrades we offer (2 a year typically) without having to buy an upgrade. This means not only will you get a new version later this spring byut if you stay in contract you will eventually get a beyind 4.x such as a 5.0.

You also get direct access to EFI technical support for Color Profiler Suite. The technical support alone is worth the annual cost of the contract. Support can always be reached at <profilersupport@efi.com>

~Lou

adam1991
04-01-2015, 05:43 PM
I'll dispute that "required by law to sell an upgrade" thing.

But the real point is, 4.0 through 4.5 were all FREE updates to all 4.x owners, no SMSA or payment required. Then all of a sudden 4.6 comes along and it requires payment and/or SMSA???

If EFI's plan was to sell or charge money for it, it should have been called a full upgrade to 5.0. In the customer's mind, 4.5 to 4.6 is an update. You know that, I know that, and the world knows that.

When you mess with your customers like that, the customers notice. And no amount of dancing will make them forget.

Lou_P
04-07-2015, 03:58 AM
Is it possible to upgrade my license from a 3x to 4.6? If so how much would that cost?

Thank You

Sure you can upgrade. $899 for Version 4.6 plus one year of SMSA coverage including all product upgrades and EFI technical support for the product.

You can buy this from your Fiery reseller or order it here
<https://estore.efi.com/shop/asp/product_info.aspx?pid=3000005455>

~Lou

Lou_P
04-07-2015, 09:58 AM
Hey, I'm really sorry if I offended you.

I probably did a poor job of explaining revenue recognition law, you can look it up online and get a better explanation that I gave you of why software companies are moving away from upgrades and to contracts in order to give customers frequent updates without unexpected upgrade charges. I'll send you my contact info in private email in case you want to talk live - maybe I can explain it better on the phone than in writing.

I want you to know that our customers including you are the most important thing in the world to us - without you we wouldn't be here! We are working hard to bring you great software and lots of new features that the SMSAs encourage us to keep working at!

You correctly recognize that we did not update the license from version 4 to 4.5. The reason is that when we ship a copy of the product, we don't know how long it will take to get to a user. The first year SMSA is actually 15 months to cover for this (and yes we recognize that first year SMSA revenue over 15 rather than 12 months, just in case the IRS is reading this).

Now look at the dates. 4.0 shipped in August 2012. Even the first customer would have been covered under SMSA until November 2013 (15 months). If you remember when 4.0 updater gave you 4.1 it said something to the effect of "An upgrade to 4.1 is available to users covered under SMSA." Then it let you download it - because it was only January 2013, at most 4.5 months into even the first 4.0 customers' SMSA coverage.

It was not free. It was an upgrade that added features (Auto Color Verifier and the first support for measuring M1 on an iO table) that users were entitled to under SMSA.

Along came 4.5 and the same thing happened. This one added the Printer Match module and Max GCR feature that many users love. it also appeared "free" but was technically only available to those under current SMSA. We still didn't force a new license since this was in September 2013 all users were was still in contract.

With version 4.6 we had to rev the license because by May 2014 we had some users covered and some with expired SMSA - so people out of SMSA coverage had to renew to get the upgrade which added Express Profiler.

I probably could have communicated about this more clearly on the forum before we shipped 4.6 when this surprised and frustrated you.

Again, my apologies.

~Lou

~Lou