PDA

View Full Version : Canon and OS X 10.9



broadwayprint
10-28-2013, 09:14 AM
Hi!

So i read the sticky about support for OS X Mavericks and I figured I would wait a week before installing it. I have downloaded, but not installed it (Mavericks) and decided to check here to make sure drivers were available. Very happy to see the support thread :)

But....
I just went to get my drivers and found that it only had an option for 10.5-10.8 available.

My machine is the Canon ImagePRESS C6000 running Fiery A1100.
I have attached a screenshot of what I am seeing from the download page.

Can someone explain to me if I can go ahead and download this because in a post by Gary_S Mac OSX 10.9 Support i think it says yes to download but I am a bit confused... "EFI is planning to update our OSX 10.8 drivers to fully support OSX 10.9"

Does this mean I can download the drivers and use them?
I am currently on 10.7.5 and I am looking to upgrade to OS X Mavericks.

Thanks for any help in advance.
Jason

jcooper
11-04-2013, 05:40 AM
Hi,

Not sure if anyone from efi reads these, but I found that the driver for 10.9 was now available for the Canon irc5185. Per the Release notes I tried to run the uninstaller to remove the old driver, and it crashes.

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
detected buffer overflow

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x00007fff909f7866 __pthread_kill + 10
1 libsystem_pthread.dylib 0x00007fff8e89435c pthread_kill + 92
2 libsystem_c.dylib 0x00007fff8ac36bba abort + 125
3 libsystem_c.dylib 0x00007fff8ac36d31 abort_report_np + 181
4 libsystem_c.dylib 0x00007fff8ac5a8c5 __chk_fail + 48
5 libsystem_c.dylib 0x00007fff8ac5a895 __chk_fail_overflow + 16
6 libsystem_c.dylib 0x00007fff8ac5aae4 __strcpy_chk + 83
7 com.efi.FierySoftwareUninstaller 0x0000000100009c64 -[EFPrinterDriverHandler getInstalledPrinterDriverDetails] + 846
8 com.efi.FierySoftwareUninstaller 0x00000001000125e8 -[EFDriverViewController awakeFromNib] + 83
9 com.apple.CoreFoundation 0x00007fff8e5af709 -[NSSet makeObjectsPerformSelector:] + 201
10 com.apple.AppKit 0x00007fff96c37b2d -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1157
11 com.apple.AppKit 0x00007fff96c2c5fe loadNib + 327
12 com.apple.AppKit 0x00007fff96c2bb9c +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 288
13 com.apple.AppKit 0x00007fff96c2b98c -[NSBundle(NSNibLoading) loadNibNamed:owner:topLevelObjects:] + 197
14 com.apple.AppKit 0x00007fff96c2b77b +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 357
15 com.apple.AppKit 0x00007fff96c27617 NSApplicationMain + 448
16 com.efi.FierySoftwareUninstaller 0x0000000100001754 start + 52

Thanks.

Bob_B
11-04-2013, 09:17 AM
Hi jcooper,

You are correct, we just completed posting additional Mac OS 10.9 compatible drivers for older Fierys later last week.

Regarding the crash of the Fiery Software Uninstaller utility, when did the crash occur? Did it occur at launch or when you were trying to uninstall a driver? Does it occur every time you try to use it? What Mac OS version are you running and what is the filename of the Fiery Driver package you downloaded?

Bob

broadwayprint
11-04-2013, 09:53 AM
Thanks for the drivers. I just downloaded them. :)