View Full Version : Mac OSX Server 10.8 Print shares - TOUGH ONE!

01-23-2013, 05:28 AM
Hi all

Ok Apple have decided to change the way print shares work on their newish server software 10.8. You do not have to enable the print service via Server Admin anymore. You now have to share printers from the print and fax area like you would if you were sharing out printers from a client Mac workstation.

So my scenario is as follows: Xerox DC 252/Fiery EX260 : Adobe CS 5.5

I create a printer using the LPD protocol on the Mac Server 10.8 and share this out so all users can print.
I connect to this share from a Mac 10.8 workstation using the bonjour shared option. I use the same installed driver on both the server and the workstation. I send a job from FireFox, and any of the Adobe design apps, and the job either comes down as 'unknown' or there is no job name at all when checking CWS.
As there is no official driver written for OSX 10.8 for this product I have also tried using the Fiery Express driver on both platforms (so they marry up) but i still get the same issue:(
If I choose to use standard bonjour and not bonjour shared Firefox's job name comes down correctly but the Adobe design apps do not:(

If I try this from a 10.6.8 workstation it works with no issues. It also works if I print from a 10.8 Workstation to Mac Server 10.6.8.

So I can only deduce there is an issue here printing from 10.8 workstation to 10.8 server.

Any ideas on why this is happening? Is there another way I can connect to the Mac server share other than bonjour or bonjour shared?

Excuse the lengthy post but I had to get it all in there:D

Cheers for reading

01-23-2013, 06:43 AM

We are now using the generic postscript driver on the Mac server 10.8 and the 10.7 Fiery driver on the Mac 10.8 workstation.

This all seems to work. I wonder - when you select the Fiery driver on the 10.8 workstation the PPD name is different to the one on the server 10.8 when you select the PPD to use when you create the printer. very strange as it is the same installer. Would this cause a mismatch somehow hence the job name is coming down as 'unknown'?

Anyway the above workaround is working for us now so fingers crossed:).