View Full Version : 2GB limit?

06-21-2010, 03:48 AM

It seems that the bustled Fiery controller on our Xerox DC252 has a 2GB file size limit for printjobs. Wow, I thought those limitations shouldn't matter with modern filesystems...

Any chances that EFI could fix this?

07-09-2010, 12:50 PM
It's all about the OS running on the Fiery. Even the big Fierys used on the large production gear are limited to 3GB by the XP OS they run on. Until they move development to a newer platform, we will be stuck at that limit. Now, that being said, there are certainly ways to design a file so as not to create a 2 or 3 GB spool file. If your files are routinely getting that large, perhaps taking a look at how you are importing images into your design software etc. might be a help.

07-09-2010, 02:43 PM
I've been told that this is a limitaton of the Adobe PS interpreter - not the filesystem. It really has nothing to do with the OS.

I also hear that some newer Server (non-bustled) products with the latest PS interpreter may have a higher limit - around 4GB.

Still - Excellent point about taking a look at how you are importing images into your design software.


10-31-2011, 10:11 AM
hi there

Is there anything from the Fiery moderators to comment on this post? It would be nice to take something rock solid to our clients please. We have the same issue at a number of our clients unfortunately.

Thanks in advance


11-02-2011, 08:28 AM
There's no way to provide a single answer to rule them all with this question. It depends on the OS which your Fiery is running on, Fiery System SW version, and file type being printed. If you want a concrete answer, the best place to go is to whoever made the copier the Fiery is connected to since the individual specifications of each product are negotiated and agreed upon on a product-by-product basis.

11-04-2011, 07:46 AM
Hi Nick

Ultimately that is a dead end. No OEM has this answer unfortunately. I have tried going through every channel with Xeroxs to find a definitive answer. The only time I have seen this issue is on a Xerox DC 252 and an EX260 running Windows XP.

If the "disk full" error pops on the Fiery using the system mentioned above what is the problem? What is the limit set on this Fiery device and why? How is this limit set? If you use a standard tcpip port it goes through without an issue. So it is only LPR?

Getting a better understanding of the above will give me something to work with our clients with these devices.



11-04-2011, 08:22 AM
I'm sorry that you're running into a dead end on this with Xerox. I was answering the general question of "what's the limit" with the fact that it depends on many things. For your specific product, I'll have to defer to someone who's an expert on it (you may have noticed that EFI moderators are all proficient in different areas).

But yes, file size limits you may run into. And this is just on the Fiery Server:

Operating System limits
Adobe CPSI limits
File format limits

Also, those limits all interact with each other--adding to the confusion.

I'm not aware of any disk full errors caused by this kind of thing though. Usually when a file gets to be too big, it will error out at some level and everything else proceeds normally. Where are you seeing that error message occur?

11-07-2011, 02:29 AM
Hi Nick

Thanks for the response. Basically everytime a file spools to bigger than 2gb the disk full error appears on this device. The file we were testing spools to 2.7gb.

The file is printed from a Mac from Indesign (the tests we have run have only been from indesign). Ultimately the client does not want to create PDF's. It seems strange that if I print this same file to a Imagepass A1 (same system 8 R2) it doesn't flash up the disk full message in CWS.

Any thought of how we can overcome this?



11-10-2011, 02:40 AM
Well it seems as though it is a WIn XP SP2 limitation. Are we able to upgrade XP to SP3 from MS? Or does it cause the rip to fail if you did this?:confused:



Anders Juul Jensen
11-11-2011, 10:48 AM
I've had a similar issue with a Xerox Workcenter 7345 and a "office controller"...
The issue here was that the LPD port on the workcenter had a timeout set to about 30 seconds.

So when the customer tried to RIP the 4GB indesign document the Workcenter recieved the first page then sent a "job cancel" to the RIP. So I increased the timeout on LPD to about 300 seconds which solved the issue.

However on a DC-series im quite certain you can't find the LPD but give it a go ...
login from the RIP via

11-16-2011, 12:34 PM
The Limit of 2GB per File is a limitation of the LPR-Protocol.

11-17-2011, 02:32 AM
If that is the case why do we not get the issue on the EX560?

12-12-2011, 02:26 AM
The Limit of 2GB per File is a limitation of the LPR-Protocol.

Yes, that's right. Still this doesn't explain why I can't "print to file" and then manually import this file into the CWS. I guess, it's a limitation of the Fiery system in general. I've already printed such large files on (PS-enabled) Large Format Printers, like HP's DesignJet without any problems.

My system is a bustled Fiery, attached to a Xerox DC252. And I don't need to tell you what's Xerox answer to my little problem, do I??

12-12-2011, 05:04 AM
It may be a file system limitation on the bustled Fiery. (Remember convincing yourself how you could save money by getting the bustle?)

Try importing your PS file to the Direct queue in CWS. File-Import Job (not drag and drop into CWS).

12-12-2011, 05:12 AM
Well, nobody told me about this restriction but, are you sure the EXP Fiery don't have the same problem? I'm also using an EXP4110 (b/w), which is WinXP based. It has the same problem...

I mean, I'm using Fiery RIPs since almost 12 years now and I was quite shocked that those limitations still exists.

Nevertheless, thanks for your tipp regarding the "import" function. Unfortunately, the jobs still disappears directly after submission.

12-12-2011, 03:35 PM
The EX for 4110 has the exact same problem bringing 2GB files in to the Hold queue, independent of any lpd/lpr restrictions?

Then it's an issue with the Fiery printing service itself, is my guess.

So you file-import using CWS to the Direct queue, and the job disappears? It shouldn't; the Direct queue is a streaming queue, and the file system isn't in play. It should grab and rip and print as it goes, never even knowing or caring how large the job is.

Make sure your import settings are set to the Direct queue and not the Hold or Print queue.

Is this PDF or Postscript? If it's Postscript, are you missing some showpage operators? If it's PDF, is it Red Book compliant PDF--with each page self contained?

12-12-2011, 11:11 PM
Indeed I already tried the Direct queue and there, it magically disappears... If I'm using the Hold or Print queue, the job will (at least) appear in the Printed queue, but with a size of 0 bytes.

In my point of view, it isn't a fs restriction because on the EX4110, EFI uses NTFS for all relevant partitions and as far as I can guess, EXT3 is used on the DC252 bustled controller.

The file I was trying to send is a PS file which is produced using the Fiery's printer driver, exactly as I would print regularly, except that I've redirected the output to a file. So I guess, the file should be okay.