View Full Version : fiery features issues on Mac OS 10.6.3

06-09-2010, 12:41 PM
my office recently changed printers to a canon imagepress C1+ and i upgraded to a new mac running 10.6.3. we have downloaded and installed the latest driver from canon.

the "full properties" glitch is known by apple, as is a workaround:

This Full Properties view is no longer accessable under Mac OS X 10.6. Therefore, if you want to perform a function that is available in the Full Properties view but not currently available via the Quick Access pane, then you will have to add the function to the Quick Access pane via the Customize button from the Fiery Features menu.

however, for some reason image shift is NOT in the list of features i can add to the "quick access" pane.

now i've discovered another glitch.
when i send a file from indesign and tell it to staple - upper left, the staple ends up on the lower left. even if i send the file with NO stapling selected, then turn on stapling using the command workstation, same result. however, if i send the same file from another computer running OS 10.5.8, the stapling works fine.

06-09-2010, 12:51 PM
Hi Processor93,

Thanks for your post.

That's certainly odd behavior.

There isn't anything different in our 10.6 drivers that should cause staple location to be different than with our 10.5 drivers.

Can you please indicate which exact Fiery model and version is connected to your C1+ engine and which driver you downloaded from Canon's website?

Many Thanks,


10-13-2010, 05:50 AM
We have a Konica Minolta C451 with a Fiery IC-409 controller. We used to use OSX 10.5 with no problems (as it supported Appletalk), but now with OSX 10.6.3 we constantly get the message Error:/Library/Printers/efi/Filters/fierycupsfilter failed
We have updated the drivers but to no avail.
We have tried IPP and LPD protocols but neither seems to want to work.
We can print via our old iMac through shared bonjour printing but not direct.

Any help please.